Ongoing Degradation to APIs and Portals

Incident Report for SpyCloud

Resolved

This incident has been resolved. We are continuing to monitor stability.
Posted Oct 21, 2025 - 09:10 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 09:08 CDT

Monitoring

We’re continuing to work with AWS on the underlying issue. At this time, our APIs appear stable and fully operational. We’ll continue to monitor and provide further updates as needed.
Posted Oct 20, 2025 - 16:03 CDT

Identified

We are aware of ongoing degradation in all of our solutions. We are working closely with AWS in order to return them to normal.
Posted Oct 20, 2025 - 10:47 CDT
This incident affected: Websites (Customer Portal, spycloud.com, Cybercrime Analytics Portal) and APIs (Enterprise API, Service Provider API, NIST API, Investigations API, Prospecting API, Session Identity Protection API, Identity Risk Engine API, IDLink API).