Logins to Cybercrime Analytics Portal are failing

Incident Report for SpyCloud

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 14:41 CDT

Monitoring

The authentication vendor has come back online and we are currently monitoring for stability.
Posted Mar 25, 2025 - 14:00 CDT

Investigating

Due to an issue with our third party authentication provider, logins to the Cybercrime Analytics Investigations Portal are currently unavailable. Our team is working with the provider to identify a resolution
Posted Mar 25, 2025 - 13:25 CDT
This incident affected: Websites (Cybercrime Analytics Portal).